


FREENAS MINI 
STORAGE APPLIANCE

IT SAVES YOUR LIFE.

How important is your data? 

Years of family photos. Your entire music 
and movie collection. Office documents 
you’ve put hours of work into. Backups for 
every computer you own. We ask again, how 
important is your data?

now imaGinE LosinG it aLL 

Losing one bit - that’s all it takes. One single bit, and 
your file is gone. 

The worst part? You won’t know until you 
absolutely need that file again.

tHE soLution 

The FreeNAS Mini has emerged as the clear choice to 
save your digital life. No other NAS in its class offers 
ECC (error correcting code) memory and ZFS bitrot 
protection to ensure data always reaches disk 
without corruption and never degrades over time. 

No other NAS combines the inherent data integrity
and security of the ZFS filesystem with fast on-disk
encryption. No other NAS provides comparable power                                    
and flexibility. The FreeNAS Mini is, hands-down, the 
best home and small office storage appliance you can 
buy on the market. When it comes to saving your 
important data, there simply is no other solution.

Example of one-bit corruption

the mini boasts these state-of-the-
art features:

8-core 2.4GHz Intel® Atom™ processor •	
Up to 16TB of storage capacity•	
16GB of ECC memory (with the option to upgrade •	
to 32GB)
2 x 1 Gigabit network controllers•	
Remote management port (IPMI)•	
Tool-less design; hot swappable drive trays•	
FreeNAS installed and configured•	

with over six million downloads, 
Freenas is undisputedly the most 
popular storage operating system  
in the world.

Sure, you could build your own FreeNAS system: 
research every hardware option, order all the 
parts, wait for everything to ship and arrive, vent at 
customer service because it hasn’t, and finally build it 
yourself while hoping everything fits - only to install 
the software and discover that the system you spent 
days agonizing over isn’t even compatible. Or...

makE it Easy on yoursELF

As the sponsors and lead developers of the FreeNAS 
project, iXsystems has combined over 20 years of 
hardware experience with our FreeNAS expertise to 
bring you FreeNAS Certified Storage. We make it 
easy to enjoy all the benefits of FreeNAS without 
the headache of building, setting up, configuring, 
and supporting it yourself. As one of the leaders in 
the storage industry, you know that you’re getting the 
best combination of hardware designed for optimal 
performance with FreeNAS.

Every Freenas server we ship is... 

Custom built and optimized for your use case  »
Installed, configured, tested, and guaranteed to work out  »
of the box 
Supported by the Silicon Valley team that designed and  »
built it 
Backed by a 3 years parts and labor limited warranty »

As one of the leaders in the storage industry, you 
know that you’re getting the best combination 
of hardware designed for optimal performance 
with FreeNAS. Contact us today for a FREE Risk 
Elimination Consultation with one of our FreeNAS 
experts. Remember, every purchase directly supports 
the FreeNAS project so we can continue adding 
features and improvements to the software for years 
to come. And really - why would you buy a FreeNAS 
server from anyone else?

 Freenas 1u  
Intel® Xeon® Processor E3-1200v2 Family •	
Up to 16TB of storage capacity•	
16GB ECC memory (upgradable to 32GB)•	
2 x 10/100/1000 Gigabit Ethernet controllers•	
Redundant power supply•	

Freenas 2u  
2x Intel® Xeon® Processors E5-2600v2 Family •	
Up to 48TB of storage capacity•	
32GB ECC memory (upgradable to 128GB) •	
4 x 1GbE Network interface (Onboard) - •	
(Upgradable to 2 x 10 Gigabit Interface)
Redundant Power Supply•	

Intel, the Intel logo, the Intel Inside logo and Xeon are trademarks of Intel Corporation in the U.S. and/or other countries.Intel, the Intel logo, Intel Atom and Intel Atom Inside are trademarks of Intel Corporation in the U.S. and/or other countries.

FREENAS 
CERTIFIED  
STORAGE 

http://www.iXsystems.com/mini http://www.iXsystems.com/storage/freenas-certified-storage/

http://www.iXsystems.com/mini
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Dear Readers,

Getting to Grips with the Gimp  by Rob Somerville

Now, you have   the Best of BSD issue that is a collection 

of Rob Somerville’s articles. 

In the BSD series on image manipulation and design, 

you will read about graphic design basics, and how to 

use the most popular Open Source graphics software 

– The Gimp.

Enjoy reading,

Ewa & BSD team
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It might seem strange having a “non-technical” how-to 
series, but in this age of digital photography, graphics 
intensive website design and visual icons, more and 

more emphasis is being placed on imagery as a method 
of communication. Good graphic design is also useful for 
presentations, flyers, and publications; the list is endless. 
Some people just lift images from Google or make use of 
professional stock images, the latter being expensive and 
the former dubious from a copyright perspective. Wha can 

be more satisfying than manipulating and creating your 
own artwork?

I first became hooked on graphics programs in the mid-
eighties when I got my hands on an Amiga and Deluxe 
Paint. Sadly no more, I spent years working with other 
vector based programs such as Corel Draw, Arts and Let-
ters, etc. until I came across the Gimp in the early days of 
Open Source. While Adobe Photoshop has always been 
around, it was (and still is) prohibitively expensive for the 

Getting to Grips with 
the Gimp – Part 1
In our new series on image manipulation and design, we 
will look at graphic design basics, and how to use the most 
popular Open Source graphics software – The Gimp.

What you will learn…
•	 How to manipulate images like a design pro

What you should know…
•	 General PC administration skills

Figure 1. Raster and Vector images
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amateur design enthusiast, and un-
til the Gimp arrived there was no real 
raster based alternative. 

The Gimp (the GNU Image Manipu-
lation Program) can be used for pho-
to retouching, image authoring and a 
host of other functions including creat-
ing animated GIFs, etc.

While both vector and raster based 
programs have their uses, the former 
is mainly used for posters, logos and 
artwork that requires high definition 
at high resolutions. Gimp on the oth-
er hand works at the pixel level and 
therefore is suitable for image manip-
ulation. For vector graphics manipu-
lation, Inkscape is an excellent Open 
Source tool. [See Figure 1 – Raster 
and Vector graphics].

Requirements
The Gimp is available for Mac (OSX), 
Windows and virtually every flavour of 
Linux and *BSD. While version num-
bers may vary slightly across plat-
forms, I will be using 2.8.4 for this tu-
torial though some platforms may still 
be on 2.6.x. There are some subtle 
differences between the two versions 
(e.g. window docking, file import and 
export, etc.) but the majority of func-
tions are the same. What is more im-
portant than the version is the PC you 
run the software on. You will need 
plenty of RAM if you are going to be 
working with large images. A good 
quality graphics card and monitor are 
also important, but most modern kits 
will be fine. The biggest issue is colour 
drift and lighting – editing an image on 
a CRT monitor under flourescent light 
will be a different visual experience 
from using an LCD or LED monitor un-
der tungsten lighting. One of the rea-
sons why graphic designers are fanat-
ical about Mac’s is the excellent colour 
balance and font support, something 
that is not consistent across different 
manufacturers.

Figure 2. Default Gimp layout

Figure 3. Single window mode
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Also, it is important to respect copy-
right and attribute credit where it is due. 
All images used in this series will either 
come from the author’s own collection, 
royalty free from http://www.sxc.hu or 
under a Creative Commons licence.

Your Chance to Contribute 
If you have an image you would like 
manipulated, or have some ideas for 
the series, please contact me via BSD 
magazine. While my favourite task is 
taking mundane images and apply-
ing liberal doses of satire, surrealism 
or atmosphere, I am open to sugges-
tions and any commissions from read-
ers.

Let’s get started
Install Gimp on a PC and platform 
of your choice, either via your pack-
age management system or by down-
load from www.gimp.org/downloads. 
Upon opening the Gimp, you will be 
presented with multiple windows [Fig-
ure 2]. As I am left handed and I don’t 
like multiple floating windows clutter-
ing my desktop, I have selected Win-
dows → Single-Window mode [Fig-
ure 3]. I have also moved all the tabs 
from Layers, Brushes, Gradients etc. 
across to the left hand side dock, and 
expanded the width slightly so all the 
controls are visible [Figure 4]. You 
may want to tweak the default settings 
as well [Figure 5 – 8].

Figure 5. Use a smaller theme to increase desktop real estate

Figure 4. Controls moved to the left hand side

Figure 6. Show brushes and images

http://www.sxc.hu
http://www.gimp.org/downloads
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Editing an image
A list of the major tools and functions 
is listed in Table 1. In the belated spirit 
of St Valentines day, we will modify a 
picture of a rose and add a shadow 
using a mask and multiple layers to 
produce the resulting Image 2. These 
two tools are very powerful, and quick-
ly allow the designer to transform an 
image with ease.

Figure 8. Increase undo levels and undo memoryFigure 7. Set the default template size

Image 2. The final picture

Image 1. rose-with-bud-ii-1436558-m.jpg
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Step 1
Download rose-with-bud-ii-1436558 
-m.jpg (Image 1) from the website list-
ed in Table 2. Open in the Gimp using 
File → Open

Step 2
Rotate the image with Image → Trans-
form → Rotate 90 Degrees anti-clock-
wise. Zoom in by pressing + a couple 
of times or click on the image with the 
Zoom tool [Figure 9].

Step 3
Using the fuzzy select tool, click on 
the image at position 100px x 50px 
to make a selection. You will see 
a boundary of “marching worms” 
[Figure 10].

Step 4
Click on the Toggle quick Mask icon 
just to the bottom Left Hand Side of 
the image or press Shift Q. A red mask 
will cover the areas that will not be af-
fected by our changes [Figure 10].

Figure 10. Fuzzy select

Figure 9. Image loaded into the Gimp. New layer and mask icons highlighted
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Step 5
Using the erase tool, and increas-
ing / decreasing the size of the brush 
as required, remove the mask from 
the background to leave the rose, 
the stem and a few leaves. Zoom in 
and out as required (+ / – ), and don’t 
worry if you overshoot slightly. Either 
press Ctrl Z to undo, or retouch with 
the paintbrush tool. I used the 2. Hard-
ness 025 brush circular, but choose 
a brush you feel comfortable with. The 
final result should look like Figure 11. 
[Figure 11 – 12].

Figure 12. Final masked area

Figure 11. Mask toggled on
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Step 6
Un-toggle the Quick Mask and the 
flower with leaves should be selected 
[Figure 13]. 

Step 7
Press Ctrl, and the background will be 
filled with a black background. Press 
Shift Ctrl A to deselect the background 
and zoom out to 100% [Figure 14]. 

Figure 14. Rose on black background

Figure 13. Selected area with “marching worms”
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Step 8
From the menu Image → Canvas size 
resize the image to 300px x 410px. 
Ensure the chain between width and 
height is broken and that Resize lay-
ers → All layers is selected. Click on 
the layers icon and add a new black 
layer. Drag this new layer down so 
the rose is the top layer. Right click 
on the rose layer and add transpar-
ency by adding a new Alpha chan-
nel, then using the rectangular select 
tool, highlight the white area beneath 
the rose. Press Del to delete this se-
lection, then press Ctrl I to select the 
upper part of the image. Press Ctrl C 
to copy, click on the lower black layer 
and press Ctrl V to paste the selec-
tion. Using the move tool, adjust the 
copy of the rose so that it is roughly 
below the first top rose, then select 
Layer → Transform → Flip vertically. 
Use the move tool to adjust the po-
sition of the lower layer so that ap-
proximately 1/3rd of the inverted rose 
is showing. When satisfied, right click 
on the floating selection and choose 
Anchor layer. [Figure 15].

Figure 15. Rose with inverted reflection before top layer erased and transparency / blur 
applied

Step 9
Click on the top rose layer. Using the 
erase tool, remove just enough of the 
top black area to make the reflection 
look convincing. Add a new black lay-
er with 65% transparency between 
the rose and the reflection. Select the 
bottom layer and blur by 6px using Fil-
ters → Blur → Gaussian blur. Crop the 
image using the crop tool and the fin-
ished result can be seen in Image 2. 
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Tool Description and usage
Rectangle select.

Ellipse select

Free select

Fuzzy select

Colour select

Scissors select

Foreground select

Paths tool

Colour picker

Zoom

Measure

Move

Alignment

Crop

Rotate

Scale

Shear

Perspective

Flip

Cage transform

Text

Bucket fill

Blend

Pencil

Paintbrush

Eraser

Airbrush

Ink

Clone

Healing

Perspective clone

Blur / sharpen

Smudge

Dodge / burn

Foreground / 
background colours

Layers

Tool options

Brushes

Patterns

Gradients

Channels

Paths

Undo history

Configure tab

Table 1. Major tools and functions
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Table 2. Details and credits

Image URL Details and credits
Image 1 http://www.sxc.

hu/photo/1436558
ROSE with BUD II
Rose blossom and nearby bud in 
vibrant color hues.
Uploaded by lance1

In the next article
We will look at improving our reflected image and lighting, shade and dark. 

ROB SOMERVILLE
Rob Somerville has been passionate about technology since his early teens. A keen advocate of open systems since the mid-eighties, he has 
worked in many corporate sectors including finance, automotive, airlines, government and media in a variety of roles from technical support, 
system administrator, developer, systems integrator and IT manager. He has moved on from CP/M and nixie tubes but keeps a soldering iron 
handy just in case.

Resources
•	 The Gimp website – http://www.gimp.org 
•	 Search Creative commons – http://search.creativecommons.org
•	 Deviant art – http://www.deviantart.com
•	 Stock.xchng – http://www.sxc.hu

a d v e r t i s e m e n t

http://www.gimp.org
http://search.creativecommons.org
http://www.deviantart.com
http://www.sxc.hu
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Getting to Grips with 
the Gimp – Part 2
In our new series on image manipulation and design, we will 
continue to look at graphic design basics, and how to use the 
most popular Open Source graphics software – The Gimp.

What you will learn…
•	 How to manipulate images like a design pro

What you should know…
•	 General PC administration skills
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In the last article we looked at the 
basics of The Gimp and created a 
rose with a reflection. In this tuto-

rial, we will look further at layers, gra-
dients, light, text and shadow and cre-
ate the image “The gimp is great”.

Step 1
From File → new (or Ctrl N) create 
a new 640 x 480 image using the 
640 x 480 template [Figure 1 – 2].

Figure 2. Our 640 x 480 canvas

Figure 1. Create a new image
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Step 2
Pick a light foreground colour and 
a light background colour. I have used 
6e53e0 for the foreground and 000000 
(Black) for the background [Figure 3].

Step 3
Select the Blend tool with a radial 
shape. Ensure the gradient is FG to 
BG RGB [Figure 4].

Figure 3. Select colours and gradient mode

Figure 4. Changing the gradient direction with the gradient arrows
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Step 4
Move the cursor to half the foreground 
and height of the image (320 x 240). 
Click on the middle of the screen, 
press Ctrl to constrain the angle to 45 
degrees, and drag to the bottom edge 
of the image. This will create a gradu-
ated background [Figure 5 – 6].

Figure 5. Using the position indicator to move cursor to the centre of the image

Figure 6. The background gradient
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Step 5
Click back onto the layers tab and cre-
ate a new transparent layer. Either 
right click in the layers area or click on 
the New layer icon [Figure 7].

Step 6
Using the text tool, click and drag an 
area in the middle of the screen and 
add the text “The gimp is great.” High-
light the text, and change the font 
size, character spacing and colour so 
that a new text layer is created. Don’t 
worry about the exact position, as we 
can adjust this later. We will now have 
three layers as the text tool automati-
cally creates a new layer [Figure 8].

Figure 7. Adding a new layer

Figure 8. Adding text
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Step 7
Click on the text layer and then on  
the move tool and align the middle 
of the centre of the “p” in “gimp” so 
that the brightest area of the gradient 
shines through.

Step 8
Click on the transparent layer we made 
earlier. Reverse the background and 
foreground colour by clicking on the 
small arrow between the foreground 
and background. Click on the gradient 
tool and change the fill to Bi-Linear. 
Click inside the “p” and drag at 45 de-
grees just below the text area. Ensure 
the darker colour is on the right hand 
side of the gradient [Figure 9].

Step 9
Click on the layers tab and then on the 
mode dropdown. Scroll through the 
options and choose the effect you like 
best. I have used the difference mode 
[Figure 10].

Figure 9. Adding another layer

Figure 10. The merged layers (Difference)
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Step 10
Click back onto the text layer and right 
click on the layer choosing Alpha to 
selection to select the text. Add a new 
transparent layer and click on it [Fig-
ure 11].

Step 11
Pick a vibrant foreground colour, and 
click on Select → Grow and grow the 
outline by 2px. Press Ctrl, to fill with 
your chosen colour. Drag the layer be-
low the text layer.

Step 12
Select Filters → Light and Shadow → 
Drop shadow and create a 45 percent 
opacity drop shadow in white. Hide 
the shadow layer [Figure 12 – 13]. 

Figure 11. Alpha selection grown with yellow outline

Figure 12. Blurring the drop shadow

Figure 13. Drop shadow in place
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Figure 15. Layer on top

Step 13
Create a new transparent layer and 
ensure it is enabled. Select Filters → 
Light and Shadow → Supernova and 
create a vibrant pink flare at position 
320 x 240 with Radius and Spokes 50 
and maximum hue [Figure 14 – 15].

Step 14
Drag the layer behind Layer #1 and 
select Grain extract mode and 25% 
opacity Adjust so that the centre of the 
nova is in the middle of the “p” [Fig-
ure 16].

Figure 14. Adding a multi-hue supernova

Figure 16. Layer behind text in grain extract mode and decreased opacity
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Step 15
Re-enable the shadow layer and drag 
below Layer #2. Adjust the opacity un-
til the opacity gives the desired effect 
[Figure 17].

Step 16
Save the image as gimp.xcf and ex-
port to PNG or JPG to use in a web-
site etc. 

Figure 17. The final image

Once you have saved your XCF file, 
experiment with the layers, opacity 
and layer mode. Try different gradi-
ents blended in different modes.

ROB SOMERVILLE
Rob Somerville has been passionate about technology since his ear-
ly teens. A keen advocate of open systems since the mid-eighties, he 
has worked in many corporate sectors including finance, automo-
tive, airlines, government and media in a variety of roles from tech-
nical support, system administrator, developer, systems integrator 
and IT manager. He has moved on from CP/M and nixie tubes but 
keeps a soldering iron handy just in case.

Resources
•	 The Gimp website – http://www.gimp.org 
•	 Search Creative commons – http://search.creativecommons.org
•	 Deviant art – http://www.deviantart.com
•	 Stock.xchng – http://www.sxc.hu

http://www.gimp.org
http://search.creativecommons.org
http://www.deviantart.com
http://www.sxc.hu
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Getting to Grips with 
the Gimp – Part 3
In the third in our series on the Gimp, we will create 
a pastiche that depicts the current political crisis in 
the Ukraine.

What you will learn…
•	 How to manipulate images like a design pro

What you should know…
•	 General PC administration skills
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There is nothing new under the sun. Inspired by a pastiche in today’s Sun-
day newspaper, we will create a graphic that portrays the current crisis in 
the Ukraine.

Step 1
Download the images listed in Table 1.
Table 1. Details and credits

Image URL Details and credits
EU Flag http://www.freeimages.com/photo/1367887 European flag in the wind Uploaded by Ayla87

President Putin http://www.fotopedia.com/items/flickr-3488093359 photo by World Economic Forum on Flickr

President Obama http://www.fotopedia.com/items/flickr-6763303437 photo by Intel Photos on Flickr

US dollar http://www.fotopedia.com/items/flickr-2630539049 photo by iChaz on Flickr

Ukraine flag http://www.fotopedia.com/items/flickr-493523361 photo by LancerenoK on Flickr

Nuclear explosion http://www.fotopedia.com/items/flickr-4926596880 photo by The Official CTBTO Photostream on Flickr

Vote now http://www.fotopedia.com/items/flickr-2999130055 photo by Theresa Thompson on Flickr

Step 2

Let’s start with the “Vote Now” image. 
As we will use this on the right hand 
side of the picture, we will have to re-
move the US stars from the sneaker. 
Open the file in the Gimp and resize 
to a width of 640px [Figure 1 and 2].

http://www.freeimages.com/photo/1367887
http://www.fotopedia.com/items/flickr-3488093359
http://www.fotopedia.com/items/flickr-6763303437
http://www.fotopedia.com/items/flickr-2630539049
http://www.fotopedia.com/items/flickr-493523361
http://www.fotopedia.com/items/flickr-4926596880
http://www.fotopedia.com/items/flickr-2999130055
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Step 3
Zoom in and, using the freehand se-
lect tool, select the blue / stars area 
from the sneaker. Paint the area white 
with the paintbrush tool or press. De-
select the area, and using the smudge 
tool, blend the greyer area of the top 
of the sneaker into the area you just 
painted. Repeat with the other foot. 
As the marching worms is not clear, 
I have turned on the mask to highlight 
the area that will not be affected by 
our paint process. Save the image as 
shoes.xcf [Figure 3].

Step 4
Open the image of the European flag. 
Using the Scissors select tool, click 
around the flag and the flagpole and 
join the nodes up at the bottom once 
you have gone round the flag. Click on 
the middle of the flag to finish the se-
lection, copy the area, create a new 
transparent and paste and anchor the 
selection. Delete the original layer. 
Using the fuzzy select tool, select and 
delete the sky areas between the flag 
and the flagpole. Crop, and save as 
flag.xcf [Figure 4].
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Step 5
Repeat step 4 with the Ukrainian flag, 
but omit the flagpole. Save as ukraini-
anflag.xcf [Figure 5].

Step 6
Open the image of the Russian Pres-
ident, and repeat step 4 so that you 
have just the leader’s face. Crop and 
save as putin.xcf [Figure 6].



TBO 01/201532

*BSD CORNERGRAPHIC DESIGN

Step 7
Open the image of the US President, 
and repeat step 4 so that you have 
just the leaders face. Crop and save 
as obama.xcf [Figure 7].

Step 8
Open the nuclear explosion image 
and crop the area of the mushroom 
cloud in the middle. Resize to width 
1024px, and adjust the canvas size to 
1024 x 768. Ensure the chain is un-
clicked, as we only want to increase 
the height. Adjust the layer to image 
size, and fill the bottom of the image 
with red picked from the bottom edge 
of the explosion. Using the smudge 
tool, blend the bottom and top of the 
image so that the hard line is erased. 
Save as image_001.xcf [Figure 8]. 
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Step 9
Desaturate the luminosity of the im-
age and add a new transparent layer. 
Fill this layer with colour 8e221d and 
alter the layer mode to saturation [Fig-
ure 9 – 10].

Step 10
Create a new transparent layer. Open 
the image of the US dollar, and scale 
to 150px. Select all, copy, and click 
back onto the nuclear background 
tab. Ensure you are on the new layer 
you created and paste the resized im-
age of the dollar near the top left hand 
side of the image. When you are hap-
py with the position of the layer, an-
chor it. Duplicate the layer, and using 
the rotate and move tool, reposition 
another copy of the dollar. Repeat un-
til you have 3 dollars. When you are 
happy with the positioning, right click 
each dollar layer and merge down. 
Rename the single layer “Dollars”, 
and scale and reposition until the lay-
er dominates the top left hand corner 
of the image [Figure 11]. 
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Step 11
Open obama.xcf and select all, copy. 
Create a new layer and paste the pic-
ture of the US president into the mid-
dle. Using the scale tool and pressing 
the Ctrl key, constrain the scale until 
you are happy with the dimensions. 
Locate the president at the bottom 
right hand side on the image. Use the 
smudge tool to remove any ragged 
blue edges. Rename the layer Obama 
[Figure 12]. 

Step 12
Repeat step 11 with the picture of the 
Russian leader and place at the bot-
tom right hand side of the image. Ro-
tate the layer so that the eyes are hori-
zontal [Figure 13].
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Step 13
Repeat with shoes.xcf but instead of 
constraining the scale tool, increase 
the height. Smudge and erase the 
legs to get a fade effect. Change the 
layer mode to hard light and delete 
any speckles that show through [Fig-
ure 14].

Step 14
Open flag.xcf, and copy and paste 
into a new layer on our pastiche. Du-
plicate the layer, flip it vertically, and 
line up the flagpole so it lines up per-
fectly over the other layer. Add a new 
transparent layer, open the Ukraini-
an flag and paste and scale over the 
right hand side of the flagpole. Use 
the smudge tool to align the edge of 
the flag against the curved part of the 
flagpole. Merge down the three lay-
ers, move the bottom of the pastiche, 
and layer to image size [Figure 15].
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Step 15
Move the flag layer just above the red 
layer. Desaturate the Obama, Putin, 
Vote and Dollar layers in turn. Create 
a new transparent layer at the top of 
the layers stack, and fill with c9c26e. 
Change the layer mode to multiply 
[Figure 16].

Step 16
With the exception of the vote layer, 
apply filter → render → pattern → 
jigsaw to Putin, Obama, and Dollars 
[Figure 17 – 18]. 
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Step 17
Using the select tool or erase tool on 
the layers in step 11, delete parts of 
the jigsaw pieces. Tidy up the rough 
edges of the jigsaw with the blur tool.

Step 18
Select the last layer and increase the 
scale width and position so that the 
mushroom cloud is in the centre. Realign 
the flag layer as required [Figure 19].

ROB SOMERVILLE
Rob Somerville has been passionate about 
technology since his early teens. A keen ad-
vocate of open systems since the mid-eight-
ies, he has worked in many corporate sec-
tors including finance, automotive, airlines, 
government and media in a variety of roles 
from technical support, system adminis-
trator, developer, systems integrator and IT 
manager. He has moved on from CP/M and 
nixie tubes but keeps a soldering iron handy 
just in case.
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Getting to Grips with 
the Gimp – Part 4
In the fourth part in our series on the Gimp we will learn 
about guides and paths.

What you will learn…
•	 How to manipulate images like a design pro

What you should know…
•	 General PC administration skills

One of the most powerful tools supplied by 
the Gimp is the paths tool. Using Bezier 
curves, selections can be made accu-

rately around curved objects, and minor ad-
justments and transformations performed 
on the selection. This selection can be 
saved as a path and applied across lay-
ers, making this function a great time-
saver when working with complex im-
ages. While Bezier curves can be 
difficult to master, with practice they 
will become an essential part of your 
toolkit. Depending on the image you 
want to manipulate, Beziers can be 
a hindrance though. Sometimes it is 
quicker just to select the outline man-
ually. We will demonstrate both in this 
tutorial, and end up with a controversial 
image with a text flowing to a path.

Lets get started!
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Part 1 – Learning Bezier curves and paths

Step 1
Create a new image 640 x 480 px.

Step 2
Using the text tool, create the letter 
“B” in pale yellow 400px high. Layer to 
image size [Figure 1]. 

Step 3
Click and drag guides from the hori-
zontal and vertical measuring ruler to 
the intersection points marked in ma-
genta [Figure 2]. Zoom in if required 
to get accurate placement, resulting in 
the screenshot shown in Figure 3.
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Step 4
Click on the paths tool and, starting at 
the top left hand side of the “B”, click 
once and a small square and circle will 
appear. If you click and drag on the 
middle of the icon, you can easily re-
position the center point. Note how the 
center of the selection will snap to the 
guides. Move the selection point back 
to the top left hand side of the “B”. 

Step 5
Click once on the 3rd vertical guide 
on the letter B which will result in a 
straight path [Figure 4]. 

Step 6
Following the 7th vertical guide to the 
first upper curved bulge of the “B”, 
click once. This will result in a straight 
path bisecting the 4th vertical guide 
and the second horizontal guide [Fig-
ure 5].
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Step 7
Holding the Ctrl key, click on the path 
where it intersects with the 5th vertical 
guide [Figure 6].

Step 8
Click and drag the center point of the 
node so it follows the curve of the “B” 
[Figure 7].
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Step 9
Click on the end node so that a square 
appears [Figure 8].

Step 10
Press the + key to zoom in (Do not 
use the Zoom tool as you will lose 
your path) and add 2 nodes where the 
two upper and lower curves of the let-
ter merge [Figure 9].
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Step 11
Zoom out using the – key on the key-
pad. Repeat steps 7-9 with the lower 
part of the upper curve and the upper 
part of the lower curve [Figure 10].

Step 12
Carry on adding nodes and adjusting 
the center point of the nodes until you 
reach the bottom left hand side of the 
“B” [Figure 11].
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Step 13
Press and hold the Ctrl key and the 
cursor will change to a union symbol 
when you hover over the node creat-
ed in Step 4. Click to join up the path 
[Figure 12].

Step 14
Repeat steps 4-13 with both inner 
areas of the “B”. Don’t forget to click 
on the end node before attempting 
to create another, otherwise you will 
have an orphan node. If this happens, 
press Ctrl Z to recover. [Figure 13].
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Step 15
Click on the paths tab to see an out-
line of the final path [Figure 14].

Step 16
Right click on the path and choose 
Path → Selection. Click on the quick 
mask button at the bottom left hand 
side of the canvas and you will see the 
masked off areas [Figure 15].
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Step 17
Un-click the quick mask and right click 
on the path dialog and choose path 
tool. Note that when you click on a 
point on the curve, adjustment “arms” 
appear that will allow you to adjust the 
curve once it has been created, rather 
than just moving the center node [Fig-
ure 16].

Part 2 – Fat cat logo

Step 1
Download the images from Table 1.

Table 1. Details and credits

Image URL Details and credits
Cat http://www.freeimages.com/photo/1432815 Closed eyes cat. Uploaded by diogoakio 

Bengal cat http://www.freeimages.com/photo/1435180 Bengal Cat on Blanket Bengal Cat lying on white Blanket in the Garden, just 
woke up Uploaded by Krappweis 

Step 2
Open the Cat image (Thanks, dio-
goakio!) and using the free select tool, 
select a rough outline of the cat. The 
fine hairs on the cat are not too impor-
tant, so don’t spend too much time on 
that part on the detail [Figure 17 with 
mask enabled to show detail].

Step 3
Click on the scale tool and ensure both 
the X and Y axis is constrained. Scale 
to 50%, and click on Edit → Copy.

http://www.freeimages.com/photo/1432815
http://www.freeimages.com/photo/1435180
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Step 4
Create a new image 1024 x 768 px 
from File → New, add a transparent 
layer and click on Edit → Paste [Fig-
ure 18].

Step 5
Anchor the layer, add another layer 
and using the ellipse select tool, cre-
ate a circle around the middle of the cat 
using Shift to constrain. Right click and 
Select → to path. Click on the paths 
tag, click on the eye and you will see 
the circular path [Figure 19].
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Step 6
Create the text “Fat cats of the world 
unite – Greed is good!” sized 16px 
Sans with a kern of 5px [Figure 20].

Step 7
Click on the layers tab and right click 
select → Text along path. Remove the 
text layer [Figure 21]. 
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Step 8
Return to the paths tab, select Path → 
Selection and press Ctrl + . or Ctrl +, to 
fill with the background or foreground 
color as desired. From the menu, Se-
lect → None [Figure 22].

Step 9
Using the scale tool, stretch the con-
tained layer to wrap around the cat 
[Figure 23].
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Step 10
Copy and paste the eyes from the 
Bengal cat and add a red layer to 
colour. Remove any colour from the 
rest of the image by inverting the se-
lection and deleting. Select an area 
of the body and scale to make a “fat 
cat”, using a combination of the blur, 
smudge and erase tool to make a 
realistic body [Figure 24].

While the resulting demo in this article isn’t perfect, time and perseverance will improve it!

ROB SOMERVILLE
Rob Somerville has been passionate about technology since his early teens. A keen advocate of open systems since the mid-eighties, he has 
worked in many corporate sectors including finance, automotive, airlines, government and media in a variety of roles from technical support, 
system administrator, developer, systems integrator and IT manager. He has moved on from CP/M and nixie tubes but keeps a soldering iron 
handy just in case.
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Getting to Grips with 
the Gimp – Part 5
In the fifth part in our series on the Gimp we will learn about 
layer masks and how to modify faces and hair colour.

What you will learn…
•	 How to manipulate images like a design pro

What you should know…
•	 General PC administration skills

Professional graphic designers are often called 
to retouch images. In this tutorial, we will take 
this one step further and transplant the face 

of one model onto another. The trickiest part of this 
exercise is matching the skin tone and making 
the appearance realistic. While no humans were 
harmed in the creation of this tutorial, my apolo-
gies to the models concerned – you look far bet-
ter in your original images!
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Part 1 – Perform a face transplant

Step 1 
Download the images from Table 1.

Step 2
Open the picture of the male model as 
a layer and zoom in around the eyes. 
Using the measuring tool, take a note 
of the distance in pixels between the 
pupils of the eyes. This should be ap-
proximately 294.7px [Screenshot 1].

Table 1. Details and credits

Image URL Details and credits
Female model http://www.freeimages.com/photo/1421971 Female model by african_fi

Male model http://www.freeimages.com/photo/1348191 Self portrait by rubenshito
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Step 3
Open the picture of the female model. 
As the lady is looking to the left and 
the man to the right, flip the image by 
performing Image → Transform → 
Flip Horizontally. Repeat Step 1 with 
the lady’s eyes; this measures ap-
proximately 215.2px [Screenshot 2].

Step 4
As we will want to keep the face in pro-
portion, we can calculate the percent-
age we want to shrink the male face 
as follows – 215.2/294.7*100 which 
works out at 73%. 

Step 5
Go back to the male model and use 
the crop tool to select the head ar-
ea. Scale the image using the scale 
tool or via Image → Scale image. En-
sure both horizontal and vertical are 
locked. Scale the image by 73.00 per-
cent. Press Ctrl A then Ctrl C to se-
lect all of the image and to copy it. 
[Screenshot 3]. 
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Step 6
Return to the female image and cre-
ate a new transparent layer. Paste 
the male face into the image (Ctrl V) 
and reduce the opacity to 55%. Notice 
how both the male and female eyes 
are roughly the same distance apart 
[Screenshot 4].

Step 7
As the lady’s head is tilted slightly, 
we will need to rotate the male face 
slightly. Using the rotate tool, select 
the layer and move the centre point 
of the rotation tool to the bottom left 
hand corner of the image. Rotate the 
image by -4.0px (You may have to ad-
just this slightly) and, using the move 
tool, align the new features to match 
the eyes and mouth area of the lower 
layer [Screenshot 5].
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Step 8
When you are happy with the position-
ing, increase the opacity to 100% and 
anchor the layer. Right click on the 
top layer and add a white layer mask. 
Roughly select the flesh coloured ar-
ea you want to transplant, Press Ctrl 
I to invert the selection, click on the 
white mask icon next to the layer pre-
view and press Ctrl, to fill with the 
foreground colour [Screenshot 6 – 7].
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Step 9
Press Ctrl Shift A to deselect the area 
and, using the paint tool, remove the 
area of the layer you do not want in-
cluded. Adjust the shape and size of 
the brush as required and decrease 
the opacity of the top layer temporarily 
so you can see the background. Se-
lect Filters → Blur → Gaussian Blur 
and apply a blur of 250px. This will 
increase the size of the mask, so go 
over the areas again with the paint-
brush until you are happy with the re-
sult and no orphan areas are visible 
[Screenshot 8 – 9].
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Step 10
Duplicate the top layer and make both 
upper layers invisible by clicking on 
the eye icon. Select the bottom layer 
and, using the colour picker tool, se-
lect a colour from just left of the lady’s 
nose. Turn the other upper layers back 
on, and select the top layer icon (not 
the mask). Fill with the foreground co-
lour by pressing Ctrl, [Screenshot 10].

Step 11
Change the mode of the top layer to 
Soft light and adjust the opacity un-
til you are happy with the skin tone 
[Screenshot 11].
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Step 12
Hide the bottom layer and right click 
to merge visible layers. Re-enable the 
bottom layer, select the top layer and, 
using the erase tool with 60% opacity, 
tidy up the area around the right eye-
brow and right eye. Using the clone 
tool, click on an area of stubble on the 
chin and repair any areas around the 
chin that do not have stubble. If need 
be, move the upper layer or scale so 
that the face looks natural. [Screen-
shot 12].

Step 13
Merge the two layers and duplicate 
the result. Select the top layer. Use 
the clone and repair tool to remove 
any fine hair that we will not be able 
to easily select as it is too fine (e.g. 
around the right shoulder) [Screen-
shot 13].

Part 2 – Change the hair colour
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Step 14
Choose the free select tool with feather-
ing and anti-aliasing enabled with add 
to current selection [Screenshot 14].

Step 15
Select the hair using the Ctrl and Shift 
keys to add separate areas or remove 
parts of the wallpaper. The more time 
you spend on this, the better the end 
result. [Screenshot 15].
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Step 16
Select Colours → Brightness – Con-
trast and decrease the brightness to 
-20 and increase the contrast to 20 
[Screenshot 16].

Step 17
Select Colours → Desaturate Lumi-
nosity [Screenshot 17].
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Step 18
Select Colours → Levels and adjust 
the input and output levels until you 
have the desired effect. Too much ad-
justment will lose contrast so we want 
to keep the highlights as much as pos-
sible. Adjust the brightness and con-
trast as required. [Screenshot 18].

Step 19
Finally, add a new layer and, using the paintbrush with 
the black colour, touch up the area around the right 
hand side of the neck with 50% transparency. Adjust 
the opacity of the middle layer to get a realistic effect 
[Screenshot 19].

While the resulting demo in this article isn’t perfect, 
time and perseverance will improve it!

ROB SOMERVILLE
Rob Somerville has been passionate about technology since 
his early teens. A keen advocate of open systems since the 
mid-eighties, he has worked in many corporate sectors in-
cluding finance, automotive, airlines, government and media 
in a variety of roles from technical support, system adminis-
trator, developer, systems integrator and IT manager. He has 
moved on from CP/M and nixie tubes but keeps a soldering 
iron handy just in case.
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Getting to Grips With 
the Gimp – Part 6
A Text Filled Vignette

In the sixth part in our series on the Gimp, we will learn 
about creating a Text Filled Vignette.

What you will learn…
•	 How to manipulate images like a design pro

What you should know…
•	 General PC administration skills

The book, “Tinker Tailor Soldier Spy” by John 
Le Carre has a vignette of George Smiley on 
the front cover. Hence, we will create a similar 

edgy picture with text rather than numbers.
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The recipe
We will follow the following steps as indicated: 

Step 1
Download the image of the fe-
male model from Table 1.

Step 2
Pull the guide down from the top of the 
measuring bar, so that it rests just be-
neath the model’s right eye [Screen-
shot 1].

Details and Credits Image URL
Joann p 02 portrait
Uploaded by obyvatel

Female model http://www.freeimages.com/photo/668970

http://www.freeimages.com/photo/668970
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Step 3
Using the rotate tool, rotate the image 
until the eyes become parallel to the 
guide [Screenshot 2].

Step 4
Using the move tool, bring the layer 
down until the chin is at the bottom of 
the frame. Use the crop tool to cen-
tre the face by removing excess areas 
[Screenshot 3].



www.bsdmag.org 67

Part 6Part 6

Step 5
Use the clone tool to the area of the 
image left transparent due to the ro-
tation. Use a large size brush to re-
create the hair on the left hand side 
[Screenshot 4].

Step 6
Zoom in each eye in turn and carefully 
select around the iris. Use the shift key 
to select the area around the second 
eye. Click on the paths tab and choose 
selection to path [Screenshot 5-6].
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Step 7
Add a new layer, pick a color for 
the eyes and fill the selected areas. 
Change the layer mode to dodge 
[Screenshot 7].

Step 8
Using the smudge tool, touch up 
around the eyes dragging the col-
or away from the edge of the iris, so 
that no sharp edges still remain. Add 
a new layer and fill with a 45 degree 
gradient from top left to bottom right. 
[Screenshot 8].
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Step 9
Add a new layer as in Step 8, and 
change the mode to dissolve. Adjust 
the opacity until you get the level of in-
terference you like. Similarly, change 
the layer in Step 8 until you get an ef-
fect you prefer. In the final version, I 
chose burn [Screenshot 9].

Step 10
Using the text tool, select the whole 
image and then enter the text you 
want as the message. This is very 
processor and graphics intensive, but 
Sans 50pt seemed to work OK on my 
elderly PC. The smaller the font, the 
more text and the slower this opera-
tion will be. Change the layer mode to 
overlay mode [Screenshot 10]. 



TBO 01/201570

*BSD CORNERGRAPHIC DESIGN

Step 11
Using the erase tool, remove all the 
text detail and gradients from the in-
side of the eyes. Experimenting with 
the text layer, duplicating it and chang-
ing the mode then trying to delete text 
from the face is a good technique.

Step 12
The final result that I saved will be 
similar as in [Screenshot 11].

ROB SOMERVILLE
Rob Somerville has been passionate about technology since his early teens. A keen advocate of open systems 
since the mid-eighties, he has worked in many corporate sectors including finance, automotive, airlines, govern-
ment and media in a variety of roles from technical support, system administrator, developer, systems integrator 
and IT manager. He has moved on from CP/M and nixie tubes but keeps a soldering iron handy just in case.
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Getting to Grips With 
the Gimp – Part 7
In the seventh part in our series on the Gimp we will retouch 
an old photo and start working with filters.

What you will learn…
•	 How to manipulate images like a design pro

What you should know…
•	 General PC administration skills

Retouching photos is a common request, and we will recreate the 
Stalinist propaganda of the removal of Nikolai Yezhov from the photo 
with Stalin to illustrate how to manipulate old images. We will then ap-

ply some filters to enhance the photograph.
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Download the image listed in Table 1.

Table 1. Details and credits

Image URL Details and credits
The Commissar Vanishes http://upload.wikimedia.org/wikipedia/commons/9/91/

Voroshilov%2C_Molotov%2C_Stalin%2C_with_Nikolai_Yezhov.jpg
Wikimedia – Voroshilov, Molotov, 
Stalin, with Nikolai Yezhov

Duplicate the original layer, hide the 
original and select the second layer.

Zoom in on the figure of Yezhov and 
select him using the free select tool. 
I have turned the quick mask on to 
highlight the area selected [Figure 1 
and Figure 2].
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Press DEL to remove Yezhov [Figure 3].

Press Ctrl Shift A to deselect the area 
and zoom in on the bottom right hand 
side of the wall [Figure 4].



www.bsdmag.org 75

Part 7Part 7

Select and copy the area of wall at the 
bottom right of the photo as a patch. 
Create a new transparent layer called 
wall and select it [Figure 5].

Following the line of the wall into the 
horizon, repeatedly paste the section 
of wall up past Stalin’s arm [Figure 6].
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Temporarily hide the wall layer and 
select a suitable area of the wall shad-
ow from the lower layer. Create a 
new transparent layer called shadow 
above wall.

Click on shadow and repeat the pro-
cess in step 7 to duplicate the select-
ed patch from Stalin’s elbow to the 
lower corner of the picture [Figure 7].

Merge the Shadow and Wall layers by 
right clicking on Shadow and choose 
Merge Down.

Give this layer 50% opacity, delete 
the overlap on Stalin’s left arm and 
return the opacity to 100% [Figure 8].
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Use the block brush (Colour E0E0E0) 
rotated 90 degrees to airbrush any 
gaps on the top part of the wall [Fig-
ure 9].

Create a new layer and using the 
airbrush tool touch up the shadow.  
Adjust the opacity of the layer to get 
a realistic appearance and merge the 
layer twice. Run the blur tool light-
ly over the sharp edges of the wall.  
Save the image [Figure 10].
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Create a new transparent layer called 
water and select a foreground patch of 
water from the lower layer. Copy and 
paste this into the new layer and work 
towards Stalin’s arm. Repeat slightly 
higher up from the bottom right of the 
image to get a realistic water pattern. 
Use the [Figure 11 and 12]

Under close examination, the modifi-
cations would not pass close exami-
nation. In particular although the wave 
pattern is fine, the contrast varies and 
is patchy. Touch this up with the dodge 
tool, adjusting the brush shape and 
size as required [Figure 13 & 14].
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Add a new layer and fill this with 50% 
grey (828282). From the filters dia-
logue, select Noise → RGB noise. 
From the Colours menu, desaturate 
by luminosity. Then change the new 
layer mode to grain extract. This will 
result in a grainy image [Figure 15].

To create a sepia toned image, dis-
able the grain layer and select Filters 
→ Decor → Old photo [Figure 16].

Congratulations, you can now join 
the ranks of the propagandists.

ROB SOMERVILLE
Rob Somerville has been passionate about 
technology since his early teens. A keen ad-
vocate of open systems since the mid-eight-
ies, he has worked in many corporate sec-
tors including finance, automotive, airlines, 
government and media in a variety of roles 
from technical support, system adminis-
trator, developer, systems integrator and IT 
manager. He has moved on from CP/M and 
nixie tubes but keeps a soldering iron handy 
just in case.
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Getting to Grips With 
the Gimp – Part 8
In the eighth part in our series on the Gimp we will look at 
how to extend the Gimp with extra add-ons.

What you will learn…
•	 How to manipulate images like a design pro

What you should know…
•	 General PC administration skills

The Gimp currently supports a number of add-ons: Brushes, Gradients, 
Patterns, Palettes, Fonts, Scripts and Plug-ins. Adding an extra re-
source is simplicity itself, once the desired add-on has been found, 

download and extract it into the relevant folder under the Gimp home folder. 
This is located in /home/username/.gimp-2.8 for the current version of the 
Gimp where username is the account you are logged in as [Figure 1].
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There are far too many resources on 
the web to list them all, but I have 
complied a list of some of the most 
popular in Table 1. 

Add a brush
Download the Aurora Borealis brush 
set from http://www.deviantart.com/
art/GIMP-Aurora-Brushes-71229165. 

Extract the Aurora directory from 
GIMP_Aurora_Brushes_by_Project_
GimpBC.zip into /home/username/.

gimp-2.8/brushes (I used Archive 
Manager for this).

Restart the Gimp – The new brushes 
will be found under the Brushes tab 
[Figure 2].

Table 1. Details and credits

Resource URL Details and credit
Deviant art http://www.deviantart.com Massive resource of Gimp extras

Abstract fonts http://www.abstractfonts.com Font resource for private and commercial use

Gimp plugin registry http://registry.gimp.org Gimp plugins and scripts

http://www.deviantart.com/art/GIMP-Aurora-Brushes-71229165
http://www.deviantart.com/art/GIMP-Aurora-Brushes-71229165
http://www.deviantart.com/
http://www.abstractfonts.com/
http://registry.gimp.org/
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Add a gradient
Download the Autumn gradients from 
http://www.deviantart.com/art/6-Au-
tumn-Gradients-for-GIMP-187205931.

Extract the 6 gradient files from 6_au-
tumn_gradients_for_gimp_by_ln213-
d33gh0r.zip into /home/username/.

gimp-2.8/gradients. 

Restart the Gimp – The new gradient 
will be found under the gradient tab 
[Figure 3].

Add a pattern
Download Glitter Gimp Patterns from 
http://www.deviantart.com/art/Glitter-
GIMP-Patterns-187921791. 

Extract the folder and contents form 
glitter_gimp_patterns_by_ jedania-
d33vtdr.zip into /home/username/.

gimp-2.8/patterns and delete the re-
adme file as this will cause an error 
message in the Gimp.

Restart the Gimp – The new gradient 
will be found under the gradient tab 
[Figure 4].

http://www.deviantart.com/art/6-Autumn-Gradients-for-GIMP-187205931
http://www.deviantart.com/art/6-Autumn-Gradients-for-GIMP-187205931
http://www.deviantart.com/art/Glitter-GIMP-Patterns-187921791
http://www.deviantart.com/art/Glitter-GIMP-Patterns-187921791
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Add a palette
Download the Touch marker palette from 
http://www.deviantart.com/art/Touch-
marker-palette-for-GIMP-108710037.

Extract the contents from Touch_
marker_palette_for_GIMP_by_dfmur-
cia.zip into /home/username/.gimp-2.8/
palettes.

Ensure the palettes tab is enabled 
via Windows → Dockable dialogues 
→ Palettes.

Restart the Gimp – The new palette 
will be found under the palettes tab 
[Figure 5].

Add a font

Download Harabara regular from 
http://www.abstractfonts.com.

Extract the TTF file from harabara_
regular.zip into into /home/username/.
gimp-2.8/fonts.

Restart the Gimp and the font will be 
available under the text button [Fig-
ure 6].

http://www.deviantart.com/art/Touch-marker-palette-for-GIMP-108710037
http://www.deviantart.com/art/Touch-marker-palette-for-GIMP-108710037
http://www.abstractfonts.com/
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Add a script
Download the Gimp Chrome script 
by Fence-post from http://www.de-
viantart .com/art /GIMP-Chrome-
Scripts-77288538 into the /home/

username/.gimp-2.8/scripts directory.

Refresh scripts by going to Filters → 
Script-Fu → Refresh scripts.

Add some text to a new image, and 
apply the filter via Filters → Alpha to 
logo → Fencepost chrome [Figure 7].

Add a plug-in
Download the G'MIC from http://reg-
istry.gimp.org/node/13469 and extract 
the content of the zip file to /home/
username/.gimp-2.8/plugins directory.

Restart the Gimp, load an image of 
your choice and run the plugin from 
Filters → G’MIC. You will now have 
an additional 400 effects you can ap-
ply to your image [Figure 8].

ROB SOMERVILLE
Rob Somerville has been passionate about 
technology since his early teens. A keen ad-
vocate of open systems since the mid-eight-
ies, he has worked in many corporate sec-
tors including finance, automotive, airlines, 
government and media in a variety of roles 
from technical support, system adminis-
trator, developer, systems integrator and IT 
manager. He has moved on from CP/M and 
nixie tubes but keeps a soldering iron handy 
just in case.

http://www.deviantart.com/art/GIMP-Chrome-Scripts-77288538
http://www.deviantart.com/art/GIMP-Chrome-Scripts-77288538
http://www.deviantart.com/art/GIMP-Chrome-Scripts-77288538
http://registry.gimp.org/node/13469
http://registry.gimp.org/node/13469
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Getting to Grips with 
the Gimp – Part 9
In the penultimate part in our series on the Gimp we will 
look at how to create a 3d package for a FreeBSD carton that 
is print ready.

What you will learn…
•	 How to manipulate images like a design pro

What you should know…
•	 General PC administration skills

In this tutorial we will create a realistic 3D object using the per-
spective tool that could potentially used for packaging any 
product. The key to this is accuracy and scaling, as any mis-

match will ruin the final image.

Download the images from Table 1.
Table 1. Details and credits

Resource URL Details and credit
FreeBSD website https://www.freebsd.org/logo/logo-basic.png FreeBSD Logo and fonts
CPU core http://www.freeimages.com/photo/759887 Gold roubles

10 russian gold roubles and CPU by styf22
Power button http://www.freeimages.com/photo/675014 Power Button

Hard drive power button 
by jmonte

https://www.freebsd.org/logo/logo-basic.png
http://www.freeimages.com/photo/759887
http://www.freeimages.com/photo/675014
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Step 2
Rescale the image to 2800px with the 
constraint disabled [Figure 2].

Step 1
Open the CPU image [Figure 1]. 
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Step 3
Select Layer → Layer to image size. 
Use the colour picker tool, select a re-
gion in the core of the CPU and fill the 
right hand side of the expanded image 
[Figure 3].

Step 4
Create a new layer and click back on 
the original layer. Select some CPU 
pins from the lower left hand side us-
ing the lasso tool, copy the selection 
and paste into the new layer. Tempo-
rarily reduce the opacity of the layer 
while aligning so you can overlay the 
pins accurately [Figure 4].
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Step 5
Open the FreeBSD logo image and 
select and copy the transparent Red 
Daemon sphere. Create a new layer 
in the CPU image and paste the re-
sult. Click on the scale tool and en-
sure the constrain is enabled. Scale 
the image to neatly overlay the coin 
[Figure 5, 6].

Step 6
Add a new layer. Hide all the other lay-
ers. Copy the transparent FreeBSD 
text in black into the new layer. With 
constrain enabled, scale to 1500px 
and anchor the layer. Add a new layer. 
Set the foreground colour to #ff3300, 
select a square bounding box around 
“BSD” and fill with red. Repeat with 
the “Free” text and fill with white. Set 
the layer to Addition. Reveal the other 
layers and move the FreeBSD text to 
the edge of the CPU die. Select Layer 
→ Layer to image size [Figure 7].
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Step 7
Set the resolution of the image to 300 
pixels/in in both axis (Image → Scale). 
Create a new image with the same 
resolution 760 × 3884 pixels. Select 
the light and dark blue from the left 
hand side of the original image using 
the pick tool and set the foreground 
and background accordingly. Switch 
to the new image and use the gradient 
blend tool to fill the new image [Fig-
ure 8].

Step 8
Scale both the side and front images 
to 50% constrained. Open the hard 
drive light image and use the clone 
tool to remove the symbol engraved 
on the right hand side. Crop so that 
the switches are central [Figure 9].
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Step 10
Merge visible layers on both imag-
es. Create a new page with a white 
background 3000 x 2500 px. Add a 
guide at 50% of the vertical (Image 
→ Guides by percent). Add a horizon-
tal guide part way down the from the 
top of the page. Create two new lay-
ers, copy and paste the side image 
and front images into separate layers. 
Add two vertical guides one aligned 
against the 'P' and one intersecting 
the “S” [Figure 11]. 

Step 9
Add a new layer to the side image and 
paste then scale the switches so they 
line up in the centre of the image. Add 
“The power to serve” text adjusting 
the kerning and size to fix the maxi-
mum width. Set the switch layer to 
hard light [Figure 10].



TBO 01/201592

*BSD CORNERGRAPHIC DESIGN

Step 11
Click on the left hand layer and using 
the square selection tool, outline the 
left hand panel. Click on the perspec-
tive tool and alight the vertical axis to 
match the left-hand guide then click 
on Transform. Anchor the layer. Re-
peat with the right hand panel and the 
right hand guide [Figure 12].

Step 12
Merge down the two layers, and add 
a shadow with 0 x offset and 20 y off-
set and blur radius. Give the shadow 
a 40% opacity. Crop and export as re-
quired [Figure 13]. 

ROB SOMERVILLE
Rob Somerville has been passionate about 
technology since his early teens. A keen ad-
vocate of open systems since the mid-eight-
ies, he has worked in many corporate sec-
tors including finance, automotive, airlines, 
government and media in a variety of roles 
from technical support, system adminis-
trator, developer, systems integrator and IT 
manager. He has moved on from CP/M and 
nixie tubes but keeps a soldering iron handy 
just in case.



Cyber Security Auditing Software

www.titania.com

Improve your 
Firewall Auditing 
As a penetration tester you have to be an expert in multiple 
technologies. Typically you are auditing systems installed and 
maintained by experienced people, often protective of their own 
methods and technologies. On any particular assessment testers may 
have to perform an analysis of Windows systems, UNIX systems, web 
applications, databases, wireless networking and a variety of network 
protocols and �rewall devices. Any security issues identi�ed within 
those technologies will then have to be explained in a way that both 
management and system maintainers can understand.

he network scanning phase of a 
penetration assessment will quickly 
identify a number of security 

weaknesses and services running on the 
scanned systems. This enables a tester to 
quickly focus on potentially vulnerable 
systems and services using a variety of tools 
that are designed to probe and examine 
them in more detail e.g. web service query 
tools. However this is only part of the picture 
and a more thorough analysis of most 
systems will involve having administrative 
access in order to examine in detail how 
they have been configured. In the case of 
firewalls, switches, routers and other 
infrastructure devices this could mean 
manually reviewing the configuration files 
saved from a wide variety of devices.

Although various tools exist that can 
examine some elements of a configuration, 
the assessment would typically end up 
being a largely manual process. Nipper 
Studio is a tool that enables penetration 
testers, and non-security professionals, to 
quickly perform a detailed analysis of 
network infrastructure devices. Nipper 
Studio does this by examining the actual 
configuration of the device, enabling a much 
more comprehensive and precise audit than 
a scanner could ever achieve. 
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Getting to Grips with 
the Gimp – Part 10
In the final part in our series on the Gimp we will wrap 
up and take a look at how to further improve your 
Gimp experience.

What you will learn…
•	 How to manipulate images like a design pro

What you should know…
•	 General PC administration skills

Over the past 9 articles, we have covered pretty 
much all the basic and intermediate skills re-
quired to use the Gimp effectively. We will now 

look at some of the softer skills and additional resources 
to improve your graphic design capabilities.

Work-flow
Under pressure of a deadline? Not sure of the result 
you will achieve by applying a particular filter? While 
Ctrl Z will get you out of many sticky situations, sav-
ing regularly in XCF will prevent you from serious frus-
tration. While hardware and software had improved 
greatly over the years, it is easy to get “drawn in” to the 
creative zone and when that keyboard or PC locks up 
a backup is essential. Remember also, that an exported 

image e.g. a JPG will not hold Gimp specific data such 
as layers etc. 

If you are processing a lot of images e.g. for a website, 
keep a copy of the image masters in a separate directo-
ry in case you inadvertently overwrite one of the images. 
This is useful where you manipulate an image and find 
something missing or wrong in the final product. It is easy 
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to miss something when you are looking at it for a long 
time, and often these little errors will not show up until the 
last moment. 

Tuning and customising the Gimp
Depending on the type of workload you anticipate you will 
be performing, you may be required to perform a number 
of repetitive tasks. For example, in web design, often im-
ages need to be scaled to a certain size. Gimp provides 
extensive hooks for key bindings that can be modified via 
edit → keyboard shortcuts. For instance, binding Ctrl Alt R 
to the scale menu item will allow the quick resizing of im-
ages to a desired size. One the size has been set, this will 
be repeated each time Ctrl Alt R is pressed.

Loading, importing and designing your own brushes, 
paths, gradients and patterns is simplicity itself, just right 
click in the white space in the toolbox area. You can then 
reuse these as desired.

There are countless additional resources on the web, 
deviantart.com being amongst one of the best.

Working with a design brief
Apart from getting inspiration, the most difficult part of de-
sign is getting the idea and concept out of the clients head 
into a format you can translate into an image or graphic. 
Don’t be surprised if you need to have 2 or more passes 
until they are happy. I always start with 3 mock ups us-
ing different styles and moods to try and gauge what is re-

quired. If the client really wants orange and blue text on 
a green speckled polka-dot background so be it, just be 
thankful it is not your company logo!

Ultimately, beauty is in the eye of the beholder, and 
sometimes going against the grain does work. Personally, 
I find when I hit that “wow” moment when it just seems 
right (often without being able to qualify exactly why). 
The whole concept has to fit, culturally as well as how the 
message is communicated. People read different things 
into different images – one landing page I did for a web-
site was approved by the communications manager and 
we both agreed the imagery was powerful, stunning and 
got the point across extremely well, while others were of-
fended. Ultimately, you will never please 100% of the peo-
ple 100% of the time. The occasional bit of controversy 
though is good if it raises the profile of the subject. 

Writing your own Gimp plug-ins
If you are a competent C programmer, the Gimp can be eas-
ily extended with a few lines of C. For more information, see 
http://developer.gimp.org/writing-a-plug-in/3/index.html.

Automated versus manual
There is a plethora of plug-ins and filters etc. available for 
the Gimp, many of them mimicking the capabilities of Pho-
toshop. However, part of the fun (and the learning experi-
ence) is developing the skill of knowing what looks good 
and how to make a good image outstanding. While an 
automated filter or plug-in may scratch that itch for instant 
gratification, understanding the underlying mechanics of 
how the image is transformed can be of great benefit.

http://developer.gimp.org/writing-a-plug-in/3/index.html
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Many of the most stunning effects are achieved by ap-
plying multiple processes and manipulating many lay-
ers and selections. Don’t be afraid to experiment, keep 
a notepad handy of the processes you have used and 
how you have arrived there.

Your work environment
If you are serious about graphic design you will need 
a decent monitor, graphics card, a way to perform co-
lour management and possibly a graphics tablet. Colours 

on a LCD display differ wildly from that on an LCD dis-
play, and colours for print appear different from those on 
screen. Lighting is also important, glare and fluorescent 
light can make it difficult if not impossible to work accu-
rately over long periods of time.

Artwork and resources
While there is nothing new under the sun, just grabbing 
images off Google for graphic design purposes is con-
sidered very bad form in professional circles. Either use 
a professional stock agency such as Istock or material 
with a Creative Commons licence. Better still, take your 
own photographs. This is particularly important when per-
forming graphic design for third parties, as their reputation 
could be at stake. 

Inspiration is another matter entirely. Few artists would 
be narrow minded enough to complain if a particular tech-
nique is copied, and will probably look upon your endeav-
ours as a compliment particularly if attributed. Getting in-
spiration is often the hardest part of design, so always be 
on the look out for new ideas and try to envisage how the 
designer has built the resulting image. 

Design tutorials 
If you cannot be a good example you will have to be a ter-
rible warning. Have a look at http://thatcaption.com/25-pho-
toshop-fails or Google Photoshop fails to learn from the mis-
takes of others. Again, it is always easy to miss something, 
so an extra pair of eyes is always helpful to spot glaring 
errors in the final proof. Be conscious though that beauty 
is in the eye of the beholder. For an in-depth set of tutori-
als on graphic design, have a look at http://www.lynda.com/
Design-training-tutorials/40-0.html. This covers techniques 
such as composition, typography, colour and logo design.

And finally
I hope you have enjoyed this series on the Gimp. It is one 
of my most treasured Open Source programs due to its 
reliability, flexibility and the fact that it has never let me 
down. Experimentation is the key, and I hope you enjoy 
working with the Gimp as much as I have.

ROB SOMERVILLE
Rob Somerville has been passionate about technology since his ear-
ly teens. A keen advocate of open systems since the mid-eighties, he 
has worked in many corporate sectors including finance, automo-
tive, airlines, government and media in a variety of roles from tech-
nical support, system administrator, developer, systems integrator 
and IT manager. He has moved on from CP/M and nixie tubes but 
keeps a soldering iron handy just in case.

http://thatcaption.com/25-photoshop-fails
http://thatcaption.com/25-photoshop-fails
http://www.lynda.com/Design-training-tutorials/40-0.html
http://www.lynda.com/Design-training-tutorials/40-0.html


Using FreeBSD as a File Server with ZFS
Ivan Voras

The ZFS storage workshop will teach you how to create a ZFS file system from scratch and build a file server on top 
of it, but it will also teach you how ZFS, file systems and storage servers work in general. You will learn what ZFS 
looks like, its many features and quirks, and how to use it in a FreeBSD server as a building block of a small file 
server.

ZFS is the ground-breaking file system originally developed at Sun Inc. for their Solaris operating system. It was 
open-sourced as a part of their OpenSolaris initiative and from there has spread to multiple other operating systems. 
FreeBSD was the first one to implement a working port, and though it has taken a fairly long time of tweaking and 
stabilization, it is now a robust and popular choice. There are products which successfully build upon the technolo-
gies of FreeBSD and ZFS, such as FreeNAS and its related enterprise-class products from iXsystems, which au-
tomate and simplify a lot of the tasks, but all of them use the same ZFS interface under the hood, which is not that 
complicated in itself.

The requirements for this workshop are decent knowledge of FreeBSD, a basic familiarity with command-line op-
erations, and a system (possibly a virtual machine) on which the student will perform the required tasks, containing 
at least four hard drives (physical or virtual). Since the topic of this workshop is file servers, the participants must 
prepare a virtual or a physical machine with at least two disk drives (and preferably 4), which which to perform the 
exercises and the setup from the workshop. 

http://bsdmag.org/course/using-freebsd-as-a-file-server-with-zfs-2/

Ivan Voras is a FreeBSD developer and a long-time user, starting with FreeBSD 4.3 and throughout all the versions since. 
In real life he is a researcher, system administrator and a developer, as opportunity presents itself, with a wide range of 
experience from hardware hacking to cloud computing. He is currently employed at the University of Zagreb Faculty of 
Electrical Engineering and Eomputing and lives in Zagreb, Croatia. You can follow him on his blog in English at http://
ivoras.net/blog or in Croatian at http://hrblog.ivoras.net/, as well as Google+ at https://plus.google.com/+IvanVoras.

Our courses are available online in Premium Membership.

http://bsdmag.org/course/using-freebsd-as-a-file-server-with-zfs-2/
http://ivoras.net/blog
http://ivoras.net/blog
http://hrblog.ivoras.net/
https://plus.google.com/+IvanVoras


A BZ Media EventBig Data TechCon™ is a trademark of BZ Media LLC.

www.BigDataTechCon.com

April 26-28, 2015
Seaport World Trade Center Hotel

Big Data TechCon is the HOW-TO technical conference
for professionals implementing Big Data solutions 
at their company

Choose from 55+ classes and tutorials!

Come to Big Data TechCon to learn the best ways to:
• Process and analyze the real-time data pouring into your organization

• Learn how to extract better data analytics and predictive analysis 

to produce the kind of actionable information and reports your 

organization needs.

• Come up to speed on the latest Big Data technologies like Yarn, Hadoop,

Apache Spark and Cascading

• Understand HOW to leverage Big Data to help your organization today

Big Data Gets Real in Boston!
People are talking about 

BigData TechCon!

“Big Data TechCon is a great learning 
experience and very intensive.”

—Huaxia Rui, Assistant Professor, 
University of Rochester

“Get some sleep beforehand, 
and divide and conquer the packed
schedule with colleagues.”

—Paul Reed, Technology Strategy & Innovation, FIS

“Worthwhile, technical, and a breath of
fresh air.”

—Julian Gottesman, CIO, DRA Imaging

“Big Data TechCon is definitely worth the
investment.”

—Sunil Epari, Solutions Architect, Epari Inc.



July 29-31, 2015
Sheraton Boston

• Choose from more than 75 classes and 
in-depth tutorials

• Meet Google and Google Development Experts

• Network with speakers and other Android developers

• Check out more than 50 third-party vendors

• Women in Android Luncheon

• Panels and keynotes

• Receptions, ice cream, prizes and more
(plus lots of coffee!)

Register Early and Save at www.AnDevCon.com

Right after 
Google IO!

            

            

            

          

       

                     

                     

    

    

      

                 

    

    

   

      

#AnDevConA BZ Media Event  
AnDevCon™ is a trademark of BZ Media LLC. Android™ is a trademark of Google Inc. Google’s Android Robot is used under terms of the Creative Commons 3.0 Attribution License.

Take your Android development
skills to the next level!

Android is everywhere! 
But AnDevCon is where 

you should be!

“There are awesome speakers that are willing to
share their knowledge and advice with you.”

—Kelvin De Moya, Sr. Software Developer, Intellisys

“Definitely recommend this to anyone who is 
interested in learning Android, even those who have
worked in Android for a while can still learn a lot.”

—Margaret Maynard-Reid, Android Developer, Dyne, Inc.

Whether you’re an enterprise developer, work for a commercial 
software company, or are driving your own startup, if you want to build
Android apps, you need to attend AnDevCon!
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