
Tips & Techniques 
Issue No. 5 

Welcome to the fifth 

issue of Microsoft 

Communique Tips & 

Techniques. 

There are separate issues 

of Tips & Techniques for the 

Macintosh and MS-DOS/ 

Windows platforms. We trust 

that this makes it easier for 

you to find relevant tips 

quickly. 

The topics in each version 

of Tips & Techniques are 

substantially the same, but 

readers of both versions will 

find platform-specific tips and 

techniques as well. 

If you have a problem that 

you would like us to talk about 

in a future issue, please write 

to Microsoft Communique 

Tips & Techniques, PO Box 

91, North Ryde NSW 2113. 
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Managing 

your small 

business 
There are many ways that 

you can share information 

among people in a small 

benefits of networking in a small 

business. If you want to ensure 

that there is a corporate style for 

your documents, you can place 

all your Word for Windows tem¬ 

plates on one computer. Then, if 

you change the template (for ex¬ 

ample adding a glossary entry), 

become available to everyone. 
business. You can print the But templates can be used 
information and pass it around or for more than just sharing 

o you can give your colleague a glossary entries. The story on this 

I 
disk with the information saved page shows how you can use a 
on it Word for Wmdows template to 

But there is nothing more automatically increment an 

Rp 
efficient than being able to invoice number or statement 
access the information directly number even if the invoices are 
on your colleague’s computer. being printed from different 

This is where Windows for machines. 

c>o 
1 

Workgroups is an ideal solution 

for the small business (and even NUMBERING INVOICES 

u the home if you have more than OR STATEMENTS 

one computer). Installing it is There are many occasions 

o very simple, and if you know when you need to number 

how to use Wmdows, there is documents in a small business. 

on very little extra that you need to Invoices, statements, receipts 

know before you can take and many more need to be 

advantage of the powerful file 

and printer sharing capabilities. The technique described 

In the past, the printer might here assumes that you know how 

have been attached to one to create an invoice in Word for 

machine and you had to wait Wmdows. Here you will just 

until your colleague had a cup of concentrate on how to 

coffee before you could print automatically generate the 

your document. Or, if you wanted invoice number. 

a copy of last year’s annual 

report, you would have to load it CREATING A NUMBER 

onto your computer. This had the GLOSSARY 

added and quite serious disad¬ 1 Start Word for Windows and type 

vantage of causing problems the text 
with document version control. Invoice Number: 

Having two copies of file one on the first line. 

document inevitably leads to 2 From the File menu choose Save. 

someone printing out the wrong 3 From the Save File As Type box 

one, or worse still, updating an choose Document Template. 

old copy. Notice that the directory 

There are also many other names are now ‘greyed out’. This 
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is because you can only save a 

template in the directory that you 

have specified. (Note that you 

can change the default directory 

for templates if you want to 

separate them from the WinWord 

directory. We’ll discuss how to do 

that in a future issue of 

Communique Tips & Techniques.) 

4 In the ‘File Name’ field type 

Invoice 

5 Choose OK 

6 If the Summary Sheet window 

appears, choose OK 

You have now saved the 

document as a template. Notice 

that the file name INVOICE.DOT 

appears on the title bar. 

Make sure that the text 

cursor is sitting just after the text 

‘Invoice number’. 

7 Press the SPACE BAR then type 0. 

8 Hold down the SHIFT key and 

press the <— key to highlight the 

zero. 

You are now going to create a 

glossary entry. 

9 From the Edit menu choose 

Glossary. 

The Glossary window is 

displayed (Figure 1): 

FIGURE I 

10 In the Glossary Name field type 

Number then Choose Define. 

A window is displayed that 

you might not have seen before. 

You are asked if you want to 

store the glossary entry in the 

Global template or the active 

template (Figure 2). 

You want to save this 

glossary entry in the 

INVOICE.DOT template. 

11 Choose'Ifemplate then choose OK 

You have now defined the 

number zero to be a glossary 

2 

FIGURE 2 

entry and you are returned to the 

document. 

CREATING THE MACRO 

1 Press the DEL key to delete the 

zero from your document. 

2 Now type the word Number again. 

This is the name of the 

glossary entry that will be 

changed when you create your 

document. The text should look 

like this: 

Invoice number: number 

You are now ready to create 

the macro that will automatically 

update the number each time you 

produce an invoice. 

There is a special facility in 

Word for Wmdows that enables 

you to run a macro automatically 

whenever a new document is 

created from a template. If you 

store a macro called AUTONEW 

with your template, it 

automatically runs every time 

you create a new document. 

3 From the Tools menu choose 

Macro. 

The Macro window opens. 

4 From the Show group choose. 

Template Macros. 

FIGURE 3 

Since this is a new template 

that you have created, there 

should not be any template 

macros available. 

5 Click in the Macro Name box and 

type 

AUTONEW 

A macro called AUTONEW 

will automatically be run when 

you create a new document from 

this template. 

6 Click on the Edit button. 

You are taken to the Macro 

editing window and you should 

see the commands: 

Sub MAIN 

End Sub 

These are always the first and 

last line of any macro. 

The cursor is positioned 

between the two commands. You 

are now ready to type the 

commands required for the 

macro. 

7 TYpe: EndOf Line 

then press ENTER, to move the 

cursor to the end of the first line. 

Remember that when you 

create the new document, the 

cursor will be at the beginning of 

the first line. 

8 TVpe: ExpandGlossary 

then press ENTER, to replace the 

glossary entry number with the 

value in the glossary. 

9 Type: WordLeft 1,1 

then press ENTER. This 

highlights the number you have 

just inserted into the document 

10 Type: number$ = 

Selections() 

then press ENTER. This reads the 

highlighted characters into a 

variable. 

11 Type: value = Val (number?) 

then press ENTER. This converts 

the text to a number. 

12 Type: value = value + 1 

then press ENTER, to increase the 

value ready for the next invoice. 

13 Type: number? = 

Str? (value) then press 

ENTER. This converts the 

number back to characters. 

14 Type: SetGlossary 

"number", number?, 1 

then press ENTER. This writes 

the updated number back to the 

glossary ready to be inserted in 

the next invoice. 

15 Type: CharRight 1 

then press ENTER, to remove the 



highlight from the number and 

leave it at the end of the line 

ready for you to type the rest of 

the invoice. 

Note: 

Of course you would have a much 

more involved template in real life, 

including fields that would cause 

Windows to open asking you for 

the amount and description of the 

invoice and so on. 

SAVING THE TEMPLATE 

1 From the Window menu choose 

INVOICE.DOT. 

You are returned to the Invoice 

template. 

2 From the File menu choose Save. 

The template changes are saved. 

3 From the File menu choose 

Close. 

The template is closed. 

You are now ready to try out the 

macro that you have created. 

TESTING THE MACRO 

1 From the File menu choose New. 

A list of the available 

templates is displayed. 

2 Scroll through the list until you 

see INVOICE. 

3 Choose INVOICE then choose 

OK. 

A new document is created 

based on the INVOICE template. 

Notice that the number of the 

invoice appears. 

4 From the File menu choose Close 

to close the document. 

5 Choose No to say that you do not 

want to save the changes to the 

document. 

6 Choose Yes when you’re asked if 

you want to save the changes to 

the INVOICE.DOT template. 

Unless you save the changes 

to INVOICE.DOT the new 

number will not be saved in the 

glossary. 

7 Create another new document in 

the same way and notice that the 

number increases again. 

Now any time you create an 

invoice, provided you saved the 

changes to the INVOICE.DOT 

template, the invoice number will 

automatically be increased for 

Setting multiple 
baselines in Project 

8 From the Options menu, choose 

Project Status again. 

Notice that there is a 

scheduled start and finish date 

and also planned start and finish 

dates. 

In a complex project, you 

might need to track the changes 

that have been made to the plan 

or baseline of your project as you 

move through the strategic to the 

concept to the detailed stages of 

planning. 

Using Microsoft Project 3.0 

for Windows you can easily keep 

track of multiple baselines and 

display the changes on your 

Gantt chart. 

Tty the following simple test 

of this function. 

1 Start Project for Windows. 

2 Enter a task called‘Baseline test’. 

3 F’ress TAB to move to the 

Duration field, then enter a 

duration of lOd. 

You now have a scheduled 

start and scheduled finish date 

displayed in the Task Form at the 

bottom of the screen (provided 

the Task Entry view is active). 

4 From the Options menu, choose 

Project Status (Figure 1). 

FIGURE I 

Notice that there is a 

scheduled start and finish date 

for the project but no planned or 

actual dates. 

5 Choose OK 

6 

9 Choose OK 

You now know that the 

project has to be delayed. 

1 From the Options menu choose 

Project Info. 

2 Change the Start dale in the 

Schedule Project From group so 

that it is five days later than the 

current start date. 

3 Choose OK 

4 The Gantt bar moves to reflect 

the new starting date. 

5 From the Options menu, choose 

Project Status again (Figure 2). 

FIGURE 2 

Notice that the scheduled 

start and finish dates have 

changed but that the planned 

start and finish dates have 

remained the same. This is how 

Project measures delays from the 

planned start dates. 

Choose OK 

You can display this 

graphically: 

From the View menu choose 

Define Views. 

2 Scroll through the list of Views From the Options menu choose 

6 

Set Plan. 

7 Choose OK 

The scheduled start and finish 

until you find Tracking Gantt. 

3 Choose Tracking Gantt then 

choose Set. 

dates for the project are copied 

into two fields called Planned 

Start and Planned Finish. 

Notice now that there is a bar 

for the Planned dates and one for 

the Scheduled dates. 

3 
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Imagine that you decide to 

make another change, but want 

to keep track of the original plan. 

4 From the Options menu choose 

Set Plan. 

5 Click on the drop-down arrow in 

the Into field. Choose 

Start 1/Finishl. 

You have now asked Project 

to copy the current start and 

finish dates into a different set of 

fields. 

6 Choose OK 

7 From the Options menu choose 

Project Info. 

8 Change the Start date in the 

Schedule Project From group so 

that it is five days later than the 

current start date. 

9 Choose OK 

The Gantt bar moves to 

reflect the new starting date. 

Unfortunately, the extra change 

in plan is not displayed on the 

Gantt chart. 

10 From the Format menu choose 

Palette. 

11 In the first empty Bar Name field 

type New Plan. 

12 In the Sample field choose a thin 

black bar. 

13 In the Row column type 2. 

This will create a second row 

for the new plan to be displayed. 

14 In the From field type Startl. _ 

15 In the lb field type Finishl. 

16 Choose OK 

Notice that the second plan is 

now displayed as well as the first 

plan and the current schedule: 

Publisher 2.0 
Microsoft Publisher version 

2.0 is not just a revamped release 

of version 1.0 — it’s almost a new 

package. From the introduction 

of text styles, tables, and full text 

formatting facilities that are 

similar to Word for Windows’, 

through to the facility to wrap 

text around any shaped graphic, 

Publisher now provides a very 

economical and powerful 

alternative to other popular 

desktop publishing packages. 

Here are some useful hints and 

tips if you are using Publisher 2.0. 

V) 
0. 
h 

PAGE VIEW 

Press F9 to change quickly 

between your current page view 

and the actual size page. 

DELETING A TEXT 

FRAME 

To delete a text frame, hold 

down the CTRL key and press 

DELETE. 

CHANGING FROM 

OPAQUE TO 

TRANSPARENT 

Tb quickly change an object 

from opaque to transparent, 

select it, hold down the CTRL key 

and press T. Any other text or 

graphics obscured by this object 

will now be visible. Press CTRL T 

again to make the object opaque. 

MOVING BETWEEN 

LINKED TEXT FRAMES 

To move quickly between 

linked text frames, press 

CTRL+TAB. This will select the 

next text frame in the story. Press 

CTRL+SHIFT+TAB to select the 

previous text frame. 

Alternatively, click on the 

Frame Jump Button at the top or 

bottom of the text frame. 

(/) 
h 
z 
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MOVING TEXT AND 

GRAPHICS FROM ONE 

PAGE TO ANOTHER 

When you are laying out a 

publication, you may need to 

move an object, but don’t yet 

know where it is to go. Simply 

drag it off the page onto the 

“scratch” area at the side of the 

page. It will remain visible as you 

move through the pages. When 

you have decided where to place 

it, drag it back onto the new page. 

LINKING TEXT BOXES 

Publisher can automatically 

include the text “Continued on 

page...” or “Continued from 

page...” in your linked text 

boxes. Select the text box, and 

from the Layout menu choose 

Text Frame Properties. Click 

against the “Continued” options 

to have this text and the correct 

page number automatically 

included. 

SHAPING TEXT 

Click on the WordArt button 

and drag a rectangle until it is the 

required size. Type in some text, 

then click next to the Plain Text 

option on the toolbar to choose a 

shape for the text. 

To acljust the text further, 

from the Format menu, choose 

Rotation And Effects. You can 

now rotate the text or make it 

slope forwards or backwards. 

with 20% rotation and 100% slider 

control. 



Microsoft Excel 4.0 provides 

two ways of protecting your data 

You can secure a complete Excel 

file by placing a password on it 

Users then have to enter the 

password before they can open 

the file. You can also protect 

individual spreadsheet cells by 

using the cell protection feature. 

SECURING EXCEL FILES 

WITH A PASSWORD 

There are three ways of 

preventing document files from 

being opened or saved. By using a 

combination of a protection 

password and a write reservation 

FIGURE I 

FIGURE 2 

ALLOWING SOME 

USERS TO READ THE 

FILE AND OTHERS TO 

SAVE CHANGES TO IT 

1 From the File menu choose 

Save As... 

You will see the Save As 

dialog box (Figure 1). 

2 If you haven’t already, give your 

file a name then choose the 

directory to save it in as you 

would normally. 

3 Now choose Options. 

The Save Options dialog box 

opens (Figure 2). 

4 Type a password in the 

Protection Password box and a 

Excel 4.0 passwords 
password, you can: 

• allow users with a password to 

make changes and save the 

changes to the worksheet, and 

bar all other users from reading 

the file; 

• allow some users just to read the 

file, and others to edit it and save 

their changes to it; 

• allow everyone to read the file, 

but only those who have a 

password to edit it and save their 

changes to it 

Users who can just read the 

file are able to make changes to 

the worksheet on the screen but 

they cannot overwrite the exist¬ 

ing file. They can, however, save 

the edited file with a new name. 

ALLOWING USERS 

WITH A PASSWORD TO 

MAKE AND SAVE 

CHANGES 

1 From the File menu choose 

Save As... 

You will see the Save As 

dialog box (Figure 1). 

2 If you haven’t already, give your 

file a name then choose the 

directory to save it in as you 

would normally. 

3 Now choose Options. 

The Save Options dialog box 

opens (Figure 2). 

4 Type a password in the 

Protection Password box only. 

5 Choose OK 

Excel asks you to confirm the 

password by retyping it. You’ll see 

a Confirm Password dialog box: 

FIGURE 3 

6 Reenter the password, then 

choose OK 

You are returned to the Save 

As dialog box. 

7 Choose OK to finish saving. 

Give this Protection 

password to anybody whom you 

want to be able to open, edit and 

save changes to the file. 

different password in the Write 

Reservation Password box. 

5 Choose OK 

Note: 

When Excel asks you to check 

the password, check the 

message in the dialog box 

carefully. When you type a 

protection password and a write 

reservation password you’ll have 

to re-enter the protection 

password first. 

6 Type the protection password 

again, then choose OK 

Excel now asks you to re¬ 

enter the write reservation 

password (Figure 4). 

□S3- 
FIGURE 4 

7 Type the write reservation 

password again, then choose OK 

You are returned to the Save 

As dialog box. 
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8 Choose OK to finish saving. 

Give only the protection 

password to those users who are 

to have read-only rights to the tile 

(ie people who can read the file 

but not save any changes to it). 

Give both passwords to 

people who are to be able to 

read, edit and save changes. 

ALLOWING ALL USERS 

TO READ THE FILE BUT 

ONLY SOME USERS TO 

SAVE CHANGES TO IT 

This option allows everyone 

to see the file but only users with 

a password to save changes to it. 

1 From the File menu choose Save 

As... 

You will see the Save As 

dialog box (Figure 1). 

2 If you haven’t already, give your 

file a name then choose the 

directory to save it in as you 

would normally. 

3 Now choose Options. 

The Save Options dialog box 

(Figure 2) opens. 

Spellchecking 
Often, when you spell check a 

document in Microsoft Word for 

Windows 2.0, the spelling checker 

highlights words it believes to be 

incorrect but which really are 

correct. You may not always want 

to include words that Word thinks 

are incorrect in a dictionary, but 

then every time you spell check 

the document they will be 

highlighted. To avoid this 

happening, use the Format 

Language command to tell Word 

to ignore such words when 

spelling checking. For example, 

to ignore: 

• Proper names and addresses. 

• Repeated words that are meant to 

be repeated (this sometimes occurs 

when you have the same words 

next to each other in a table). 

• Words that have been abbreviated 

for some reason. 

6 

4 Type a password in the Write 

Reservation box only, then 

choose OK. 

Excel asks you to reenter the 

write reservation password. 

5 Type the write reservation pass¬ 

word again, then choose OK 

You are returned to the Save 

As dialog box. 

6 Choose OK to finish saving. 

Now everyone will be able to 

read the file, but only those who 

can enter a password will be able 

to save changes they make to it 

OPENING A DOCUMENT 

WITH PASSWORD 

PROTECTION 

When you try to open a 

document that is password 

protected, if there is only a 

protection password then you 

will be asked to type it in before 

you can open the document. 

If there are two passwords, a 

protection password and a write 

reservation password, then what 

you do depends on the access 

in Word for Windows 2.0 
To designate a word as not to 

be spell checked: 

1 Select the word (if you have a 

mouse, double-click in it) 

2 From the Format menu, choose ' 

Language. 

This dialog box appears: 

3 In the Mark Selected Text As box, 

choose (no proofing). 

4 Choose OK 

The word will now always be 

ignored by the spelling checker. 

If the word occurs often 

rights that you have: 

if you can only read the file, type 

the protection password and at 

the next dialog box choose Read 

Only, or 

if you can edit and save your 

changes to the file, type the 

protection password then at the 

next dialog box type the write 

reservation password. 

If there is only a write 

reservation password, again, 

what you do depends on the 

access rights that you have: 

if you can only read the file, 

choose Read Only, or 

if you can edit and save your 

changes to the file, type the write 

reservation password. 

It is important to remember 

that if you forget a password your 

file will be lost forever, and that 

passwords are case sensitive. So 

be careful! 

In the next issue we will 
describe cell and 
document protection. 

throughout your document a 

quick way to set every occurrence 

of it to (no proofing) is to return 

to the top of the document, 

search for it using the Edit Find 

command and then format it as 

(no proofing). Once you’ve 

formatted the first word, press 

SHIFT + F4 (Find Again) to find 

the next occurrence then press F4 

(Repeat) to change it to (no 

proofing). Continue pressing 

SHIFT F4 followed by F4 until 

you get to the end of the 

document. 

You can also set up a text 

style specifically for paragraphs 

containing text that you do not 

want to be spell checked. Create 

a new style which has Language 

set to (no proofing). Then all text 

formatted with that style will 

automatically not be proofed. 



Placing a Print button on an Access form 
In Microsoft Access 1.1, you 

can design forms that allow a 

user to click on a button to print 

the form together with the data 

that it is currently displaying. You 

can set the characteristics of the 

button so that it is visible on the 

screen but will not be printed. 

There are two stages to this 

procedure. First you create the 

macro to do the printing. Then 

you drag it on to the form to 

create a button and define the 

button’s characteristics. 

SETTING UP THE PRINT 

MACRO 

1 Display the form on which you 

want to add the button. Make 

sure that you are in Design view. 

Typically, it may look like this: 

FIGURE I 

2 Press FI 1 to switch to the main 

database window. 

3 Click on the Macro object button. 

or FYom the View menu choose Macro. 

4 Choose New. 

5 In the Action column of the new 

macro, choose DoMenuItem. 

This indicates that you want 

the macro to execute the 

command specified in the Action 

Arguments. 

Set the Action Arguments for 

this command to be the following: 

Menu Bar. Form 

Menu Name: Edit 

Command: Select Record 

The screen should look like 

Figure 2. 

6 Click in the next Action row in 

the macro and choose Print. 

7 Set the Action Arguments for the 

FIGURE 2 

Print action to: 

Print Range: Selection 

Print Quality: High 

Copies: 1 

Collate Copies: Yes 

The important one to get right 

is Print Range. If you leave it set to 

All, you’ll print all the records. 

8 From the File menu, choose Save 

to save the new macro. 

9 Type a macro name (eg Print 

Current Form) then choose OK 

10 From the File menu, choose 

Close to close the macro window. 

SETTING THE MACRO 

UP AS A BUTTON ON 

THE FORM 

Now you have to place the 

macro button on the form. 

1 You should still have two 

windows open (the Form and the 

Database window). To check, 

choose the Window menu. If they 

are not present, open them again. 

2 Now, from the Window menu 

choose Tile to display both the 

Database window and the Form 

window (which should still be in 

Design view) together. 

3 Click and drag the macro icon 

from the Database window on to 

the form. When you release the 

FIGURE 3 

mouse button, you’ll notice a 

button on the form (Figure 3). 

4 Click on the Maximize button to 

maximize the Form window. 

5 If you want to reposition the Print 

button, move the mouse over the 

object (without holding down the 

mouse button) until you see the 

little hand showing that you can 

move it Drag it to the new loca¬ 

tion. You can also resize it by 

dragging on one of its handles. 

We now need to change the 

properties of the button to suit 

our requirements. 

6 To do this click on the Proper- rj 

ties button on the .button bar. |u 

7 Click once on the macro button 

to select it. 

8 In the Command Button window, 

click in the Display When line. 

Then choose Screen Only. 

This indicates that you only 

want to see the button on the 

screen not on the final print out. 

9 Ensure that the Enabled line is 

set to Yes. 

If it isn’t, when you click on 

the button nothing will happen. 

10 Click in the Status Bar Text line 

then type the message that you 

want to appear on the status bar 

when the button is pushed, for 

example ‘Click on this button to 

print current form’. 

The On Push option displays 

the macro name that will be run 

when the button is pushed. It 

should show the name that you 

gave the macro when you saved it 

The Command button 

window should look similar to 

Figure 5 (next page). 

You can now close the 

Command Button window. 

11 FYom the File menu, choose 

Close. 

or Double-click on the Close button 

to close it 

You should now see the form, 

which will still be in Design view. 

CONTINUED . . . 
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similar to this: 

FIGURE 5 

PRINTING THE FORM 

Tb print the form: 

1 Click on the Form button to 

switch to Form view. 

Your screen should look 

FIGURE 6 

2 Click on the button to print the 

form, together with the data that 

is currently displayed. 

Windows 3.1: Restoring a deleted icon 
Deleting a Microsoft 

Windows or Windows for 

Workgroups 3.1 icon from the 

Program Manager does not delete 

the software package’s icon from 

your hard disk. Conversely, just 

because an icon is present, it 

doesn’t meant that the software 

is. Someone may delete the 

software but not delete its icon 

from the Program Manager.) 

The icon is simply the means 

of starting up the application. Its 

properties define what 

application it should start if you 

double-click on it. 

If an icon is inadvertently 

deleted you can easily re-create it: 

1 From the File menu, choose New. 

The New Program Object 

dialog box appears. 

2 New Program Icon is already 

selected so simply choose OK 

The Program Item Properties 

dialog box appears. 

3 In the Description box, type the 

description you want below the 

icon. For example, you might type 

Excel if you are re-creating the 

Excel icon. 

4 Click in the Command Line box. 

or Press TAB to move the insertion 
point to the Command Line box. 

Here you tell Windows the 

name of the application you want 

to start and where to find it It’s 

vital that what you type here is 

correct. The best way to ensure 

this is to use the Browse option to 

locate the application. 

5 Choose Browse. 

The Browse dialog box 

appears. Notice that all files with 

the extensions .exe, .pif, .bat ,and 

.com are displayed. Most 

applications will end with one of 

these extensions so the one you 

want should appear. 

6 If necessary, in the Directories 

box, select the directory where 

the application is located. 

For example, Excel is usually 

installed in the EXCEL directory. 

Applications supplied with Win¬ 

dows (such as Calculator) are nor¬ 

mally in the WINDOWS directory. 

7 When you’ve located the file (eg 

excel.exe, clockexe or calc.exe), 

select it then choose OK 

You’re returned to the Pro¬ 

gram Item Properties dialog box. 

8 In the Working Directory box, 

type the name of the directory 

where you want the application to 

“point to’ by default when you 

open or save a document. (This is 

optional and only useful for 

applications that load and save 

files. You can use Browse here, 
too.) 

9 Choose OK 

You’re returned to the 

Program Manager and the new 

icon will appear. The image 

displayed will vary, depending on 

the application you chose. 
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